TouchFaceID

概述

TouchFaceID封装了iphone5s以后版本的手机特有的指纹识别功能,调用此插件可实现用户指纹输入验证登陆app 。使用本插件需要支持指纹识别的手机和iOS8.0以上的操作系统。

插件使用攻略

使用此插件之前需先配置项目的应用打包中faceID要勾选上然后再去打loader测试.

isValid

当前设备系统是否支持指纹识别功能

isValid()

callback(ret)

ret:

  • 类型:JSON 对象
  • 内部字段:
{
status:  //布尔类型;是否支持,true|false
code:    1:手机版本不能使用
}

示例代码

var demo = api.require('TouchFaceID');
demo.isValid(function(ret) {
if (ret.status) {
 api.alert({ msg: "支持指纹识别功能!" });
} else {
 api.alert({ msg: "不支持指纹识别功能!" });
}
});

可用性

iOS8 及以上系统

可提供的1.0.0及更高版本

verify

弹出验证界面,验证用户指纹

verify({},callback())

callback(ret)

ret:

  • 类型:JSON 对象
  • 内部字段:
{
status:  //布尔类型;是否验证通过,true|false
type:    //判断id类型
true:Face ID
false :Touch ID
code:    //数字类型;返回验证未通过信息,参数说明如下:
0.认证被系统取消(例如,另一个应用程序转到前台)
1.认证被用户取消(例如轻敲取消按钮)
2.身份验证失败,因为用户未能提供有效凭据
3.身份验证无法启动,因为设备上未设置密码
4.无法启动身份验证,因为设备上没有Touch ID或 Face ID
5.身份验证无法启动,因为Touch ID没有注册的手指
6.验证已取消,因为用户点击了取消按钮
7.其他未知错误
8.设备不支持访问,或为获得Face ID权限
}

示例代码

var demo = api.require('TouchFaceID');
demo.verify({}, function(ret) {
if (ret.status) {
api.alert({ msg: 认证被系统取消" });
} else {
if (ret.code == 0) {
api.alert({ msg: "系统取消授权" });
} else if (ret.code == 1) {
api.alert({ msg: "用户取消验证" });
} else if (ret.code == 2) {
api.alert({ msg: "身份验证失败" });
} else if (ret.code == 3) {
api.alert({ msg: "系统未设置密码 });
} else if (ret.code == 4){
api.alert({ msg: "无法启动身份验证,因为设备上没有Touch ID或 Face ID" });
}
}
});

可用性

iOS8及以上系统

可提供的1.0.0及更高版本

是否仍需要帮助? 请保持联络!
最后更新于 2024/05/31