请选择 进入手机版 | 继续访问电脑版
热门问答
更多
12下一页
返回列表 发新帖

[云开发] ios 已经弃用UIwebView apicloud打包的项目无法上架ios

[复制链接]
熊猫车服 发表于 2022-8-11 11:50:03
TMS-90809:不推荐的API使用-不再接受使用UIWebView的新应用。相反,使用WKWebView可以提高安全性和可靠性。了解更多(https://developer.apple.com/documentation/uikit/uiwebview).    apicloud打包的ios 没办法上传至苹果开发者平台了

15条回复

技术咨询-特特 管理员 4392Y币
apicloud打包的ios 也可以配置  WKWebView
技术咨询-特特 管理员 4392Y币
配置是否使用WKWebView
字段名:useWKWebView

取值范围:true|false

默认值:false

描述:若配置为true,加载页面时将默认使用WKWebView。参考WKWebView介绍

配置示例:

<preference name="useWKWebView" value="true"/>
熊猫车服 马路杀手 231Y币
不是 我在上传打包的ios包时  报我这个项目里有UIWebView的应用 导致不能上传成功  我截图给你看看哪些模板加载了UIWebView的应用
apicloud_1.png
apicloud_2.png
技术咨询-F 管理员 28872Y币
微信、支付宝相关的都换成带plus 的模块 ,如wxPlus  ,  还有美洽也一样
熊猫车服 马路杀手 231Y币
新添的alipayplus模块与原来的alipay模块冲突 而且之前alipay怎么去掉 没有看到去掉这个模块的符号
技术咨询-特特 管理员 4392Y币
把配置文件中的 alipay 相关配置去掉,提交代码就去掉了
熊猫车服 马路杀手 231Y币
然后又要重新配置alipayplus参数 然后再一起提交是吧?
熊猫车服 马路杀手 231Y币
还有个问题 我在编译ios的时候 没有选择版本了  我想重新选择一个编译的版本 请问这个在哪里去找呢
熊猫车服 马路杀手 231Y币
你好  我已经按照要求 把wx和alipay都换成了plus版本  提交的时候 苹果那边还是有这个问题   请问是怎么回事  我是把config.xml里的wx和alipay直接换成了wxplus和alipayplus               ITMS-90809:不推荐的API使用-不再接受使用UIWebView的新应用。相反,使用WKWebView可以提高安全性和可靠性。了解更多
12下一页
您需要登录后才可以回帖 登录

本版积分规则