请选择 进入手机版 | 继续访问电脑版
热门问答
更多

[模块开发] 谷歌Android 11升级引起的问题

[复制链接]
勇可可 发表于 2021-1-6 19:12:24
本帖最后由 勇可可 于 2021-1-7 09:50 编辑

如题Android 11中的queries属性必须在Android Gradle 插件升级到 4.1 Beta 版本。

目前已得知云编译环境的版本为3.0.0怎么去解决 第三方aar中AndroidManifest.xml里有 queries的问题呢。

===========================================================
好像编译可以通过  能问一下 现在云编译的环境吗   

android studio 的版本是多少

gradle/wrapper 文件下  distributionUrl的版本是多少

主工程下 build.gradle  classpath 'com.android.tools.build:gradle   的版本是多少

以下2个分别是多少呢。。
#使用的编译工具版本
ANDROID_BUILD_TOOLS_VERSION=
#使用的编译SDK版本
ANDROID_BUILD_SDK_VERSION=

6条回复

勇可可 版主 270226Y币
本帖最后由 勇可可 于 2021-1-7 09:50 编辑

          1
技术咨询-F 管理员 27776Y币
已反馈给相关技术给你解答
常山赵子云 官方版主 6530Y币
distributionUrl=https\://services**.**/distributions/gradle-4.1-all.zip
#which build-tools version to use
ANDROID_BUILD_TOOLS_VERSION=29.0.3
#set which android sdk version to use
ANDROID_BUILD_SDK_VERSION=29

云编译整体升级需要比较长的时间,短时间内来不及,如果着急,可以把aar解压,将其中的queries直接删掉,再用zip工具压缩压缩为zip后把后缀名改为aar。
勇可可 版主 270226Y币
常山赵子云 发表于 2021-1-7 09:53
distributionUrl=https\://services**.**/distributions/gradle-4.1-all.zip
#which build-tools ver ...

可是为什么 云编译 queries 可以通过?  我本地这个环境 就不行呢。
常山赵子云 官方版主 6530Y币
勇可可 发表于 2021-1-7 10:12
可是为什么 云编译 queries 可以通过?  我本地这个环境 就不行呢。

云编译和模块开发工程的配置是一样的,如果你本地没做更改,应该也编译过去。
勇可可 版主 270226Y币
常山赵子云 发表于 2021-1-9 10:03
云编译和模块开发工程的配置是一样的,如果你本地没做更改,应该也编译过去。 ...

但没有 我本地如果不升级gradle4.1 就会不通过 但是云编译可以通过 奇怪
您需要登录后才可以回帖 登录

本版积分规则