请选择 进入手机版 | 继续访问电脑版

如何解决“此应用专为旧版Android打造”问题

[复制链接]
常山赵子云 发表于 2019-7-24 09:57:02
开发者在将自己APP提交Google Play或者国内应用市场时,可能会遇到如下图中的,提示要求对目标SDK 26进行适配,即要求"兼容8.0"。

未做兼容适配的APP,在安装到Android10手机上时,系统还会弹出类似如下内容的警告提示“此应用专为旧版Android打造,可能无法正常运行。请尝试检查更新或与开发者联系。


遇到该问题时,根据该帖操作即可:https://community.apicloud.com/bbs/thread-110959-1-1.html

注意:设置targetSdkVersion为23及以上时,你的APP必须使用动态权限,否则运行过程中可能引起崩溃。

很多开发者将targetSdkVersion理解为云编译中的“固件要求”,从而理解为APICloud不适配Android8.0,这是错误的,在此指出。固件要求是指你的APP支持安装的最低系统版本,比如“固件要求”设置为5.1,那么你的APP只允许在Android5.1及以上的系统中安装,5.1以下的系统无法安装。关于targetSdkVersion的相关知识可以百度。


本帖子中包含更多资源,您需要 登录 才可以下载或查看,没有帐号?立即注册

X

1条回复

52yaoer 版主 7485Y币
支持,,,顶起。。。。。。。
您需要登录后才可以回帖 登录

本版积分规则