请选择 进入手机版 | 继续访问电脑版

云服务中,强制更新、强制关闭的简单操作介绍

技术博客 2022-4-22 10:03 297人浏览 16人回复
原作者: 常山赵子云 收藏 邀请
摘要

一、强制更新: 1、进入控制台的“版本”管理界面 2、点击右上角的“更新APP版本”,发布新的app版本:选择要发布的版本,以1.0.0为例,输入一些版本描述,或者留空;app下载链接可以从“编译记录中复制”,也可以 ...

一、强制更新:

1、进入控制台的“版本”管理界面
2、点击右上角的“更新APP版本”,发布新的app版本:选择要发布的版本,以1.0.0为例,输入一些版本描述,或者留空;app下载链接可以从“编译记录中复制”,也可以是存在自己服务器上的安装包地址
3、发布成功后,并且做推广一段时间后,你的用户手机上都装了1.0.0版本了
4、重复1、2操作,发布一个新的版本,比如2.0.0
5、此时,安装了1.0.0的用户,在启动app时,就会收到2.0.0版本的提示更新,ta可以选择不更新
6、关闭版本:在版本记录界面中,在1.0.0版本记录的最右侧,选择“关闭”,即将1.0.0版本关闭
7、此时,安装了1.0.0的用户,在启动app时,就会收到2.0.0版本的强制更新,必须更新才能继续使用
8、其他版本的强制更新以此类推。

二、强制关闭:

同强制更新逻辑一致,唯一不同的点:当你将版本管理中的所有版本关闭后,用户在启动app时,就会收到强制关闭的提示了,即该app不再使用

强制更新和强制关闭的主要逻辑:当用户手机上当前安装的版本被关闭时,如果此时服务器上有比该版本更新的版本,则强制用户更新到最新版本;如果用户手机上当前安装的版本没有被关闭时,则提示更新,用户可以选择不更新;当服务器上所有版本都被关闭时,该应用被强制关闭,用户无法再使用。注:前置条件是手机联网了。
评论
297人参与,16条评论

精彩评论
  • APICloud官方 管理员 2146344965Y币
    发表于 2015-9-14 13:34
    感谢分享
  • loveDlhd 入门司机 4511Y币
    发表于 2015-9-14 14:00
    没有代码差评
  • lalalalalala 马路杀手 3087Y币
    发表于 2015-9-14 14:06

    纯粹在网站上的操作,不用代码……
  • loveDlhd 入门司机 4511Y币
    发表于 2015-9-14 15:32
  • lcj231700764 半专业车手 19Y币
    发表于 2015-10-8 17:04
    有用~
  • 大椰子 萌萌的小学生 109Y币
    发表于 2015-10-24 23:18
    如何我发布的二维码地址是1.0版本的,我能让一些用户直接从这个二维码下载2.0版本的吗
  • 常山赵子云 官方版主 6412Y币
    发表于 2015-10-26 13:52
    二维码如果是官方生成的,那么不能。每个二维码对应的就是当时编译的安装包地址。

    如果安装包地址在你自己服务器上,二维码是你们自己根据该地址生成的,那么可以,只需要你的服务器做个处理就行了,把二维码对应地址的安装包定向到2.0上。
  • syuson 马路杀手 765Y币
    发表于 2015-11-13 16:54
    nice啊
  • kexicc 新手上路 512Y币
    发表于 2015-11-13 21:31
    收到
  • ksxt 驾校小白 38Y币
    发表于 2016-3-1 16:47
    直接把这段描述写到发布版本的那地方,不是很好么?
  • 那些青春 驾校小白 145Y币
    发表于 2017-5-16 18:47
    本帖最后由 那些青春 于 2017-5-16 18:49 编辑

    您好  我想问你下强制关闭是在哪个页面?

  • 常山赵子云 官方版主 6412Y币
    发表于 2017-5-17 11:50
    那些青春 发表于 2017-5-16 18:47
    您好  我想问你下强制关闭是在哪个页面?

    仔细看我的帖子。从头到尾用心看一遍。
  • 赵永亮 半职业车手 11017Y币
    发表于 2017-5-31 13:10
    感谢楼主
  • 半毛钱 实习司机 143Y币
    发表于 2017-8-24 23:39
    好评  正试用  3楼是逗逼吗 这个东西哪有代码 这是操作步骤
  • cys2482 驾校小白 1Y币
    发表于 2019-6-14 20:42
    提示的那个 "强制更新" 可以更改成 "版本更新" 吗
  • 常山赵子云 官方版主 6412Y币
    发表于 2019-6-14 21:09
    cys2482 发表于 2019-6-14 20:42
    提示的那个 "强制更新" 可以更改成 "版本更新" 吗

    用mam模块自己定制写检查更新代码。

查看全部评论>>